Upgrade, de okosan IV.
2005/06/08 18:06
388 megtekintés
A cikk már legalább egy éve nem frissült, az akkor még aktuális információk lehet, hogy mára elavultak.
A frissítés után célszerű konfigurációs állományainkat is átnézni.

A Debian Sarge valóban mérföldkövet jelent a disztribúció élete során. Az új verzióba több, mint 9000 (!) új csomag került, valamint közel 6500 csomag frissült. Az upgrade közben felbukkanó üzenetek arról tájékoztatnak bennünket, hogy némely program konfigurációja megváltozott. A telepítőscriptek felajánlják ugyan a régi állomány(ok) megtartását, de előfordulhat, hogy az újabb változatú kiszolgáló nem működik megfelelően, extrém esetben el sem indul a régi file-ban beállítottak hatására.Első "komoly" áldozatunk a proftpd lehet, melyben a következő változás okozhat problémát:

LsDefaultOptions "-l"
helyett a
ListOptions "-l"

direktívát kell használnunk.

Az Apache is örül pár módosításnak, igaz, ezt elegánsan a tudomásunkra hozza: a /etc/apache/suggested_corrections file-ban felhívja figyelmünket a következőre:

apache /etc/apache/httpd.conf config file declares a non standard:
MIMEMagicFile share/magic
and it should be changed to:
MIMEMagicFile /usr/share/misc/file/magic.mime
Az Apache-hoz született egy apache-modconf nevű util is, amely az egyes modulok konfigurálását segíti.

A Postfix is szolgálhat kellemetlen meglepetéssel, ha nem követtük egyik korábbi cikkünkben ( Kiegészítés a "Levelezzünk! V. - Tartalomszűrés a Postfix segítségével") lépéseit: ha az átmenő levélforgalomban a body_checks szűrést használjuk, módosítanunk kell.Ha levélszűrésre az amavis-postfix-et használtuk korábban, akkor bizony jól fel kell készülnünk: az amavis-new teljesen megváltozott beállításokkal üzemel. Konfigurációs file-ja nagyobb, komplexebb is lett, itt mindenképpen célszerű nagyon figyelmesen eljárni, hogy szűrésünk hatékony maradjon.Frissítés után, de újraindítás előtt feltétlenül futtassuk le a Lilo-t, különben rendszerünk a következő indulásnál bajban lesz. Itt jegyeznénk meg, hogy a Sarge alapértelmezett rendszertöltője a GRUB lett, igaz, ez az újonnan telepítőket érinti.A Sarge már natívan támogatja a 2.6-os kernelsorozatot. A megváltozott modulkezeléshez azonban szükség van a module-init-tools csomagra, mely a régebbi modutilst váltja fel. Kernelfrissítéskor ne felejtsük el lefuttatni a lilo utasítást.

(folytatjuk)
Béres László
beres@bkf.hu

Csatlakozz hozzánk!

Ajánljuk

European Schoolnet Academy Ingyenes online tanfolyamok tanároknak
School Education Gateway Ingyenes tanfolyamok és sok más tanárok számára
ENABLE pilot Program iskoláknak a bullying ellen
eBiztonság Minősítés Minősítési rendszer oktatási intézményeknek